Elasticsearch Specifications

Supported Versions

The following versions of Elasticsearch are supported:

  • 6.2
  • 6.0
  • 5.5
  • 5.3
  • 5.1
  • 2.3
  • 1.5

It's recommended to use the most up-to-date version. The specific version you want to use should be communicated to the Human Made team when requesting Elasticsearch be enabled.

Supported Elasticsearch Plugins

The following Elasticsearch plugins are available:

  • ICU Analysis
  • Ingest Attachment Processor
  • Ingest User Agent Processor
  • Japanese (kuromoji) Analysis
  • Mapper Murmur3
  • Mapper Size
  • Phonetic Analysis
  • Smart Chinese Analysis
  • Stempel Polish Analysis
  • Ukrainian Analysis
  • Seunjeon Korean Analysis